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1 About this user manual

This user manual contain all information necessary for operating the ›em-LINK‹ software.

The user manual is intended for technical caretakers, service and support staff, and electricians.

In addition to this user manual, the user manual ›e-touchBOX/PANEL‹ contains important 
information about the operation and configuration of the e-touchPANEL software.

The following symbols are used in this manual:

2 Short description of the program

Monitoring The program ›em-LINK‹ enables the PC-controlled monitoring of all connected e-touchPANEL of 
an emergency lighting system. The current statuses of the emergency lighting system devices are 
checked at regular intervals. In the case of errors, warnings are generated that contain the name of 
the e-touchPANEL and the type of error.

Managing the test
protocols

The relevant standards for emergency lighting systems determine the documentation of test 
protocols. The program ›em-LINK‹ stores the test protocols of the connected e-touchPANEL in an 
integrated database when they are downloaded. Thus, ›em-LINK‹ enables you to filter data 
according to various criteria, to save them in txt format, or to export them in csv format (e.g. to 
further process them in ›MS Excel‹). 

Remote control With the program ›em-LINK‹ all connected  e-touchPANEL can be remote-controlled. The 
e-touchPANEL are visualized in ›em-LINK‹, so the selected e-touchPANEL can be directly 
accessed with the mouse. 

Symbol Meaning

Notes, further information, comments or useful tips

– Prerequisite

1. One step in a sequence of actions

Single action

bold Terms and buttons of the user interface

Hint

The test protocols can only be retraced if the various e-touchPANEL of an emergency lighting 
system are not interchanged. A defective e-touchPANEL, however, can be replaced with a new 
one at any time (see "Replacing an e-touchPANEL", page 19).

Hint

Please refer to the separate user manual ›e-touchBOX/PANEL‹ for the operation and configuration 
of an e-touchPANEL.
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2.1 System topology
The PC where ›em-LINK‹ is installed is connected with the e-touchPANEL via an Ethernet 
interface. The e-touchPANEL are connected with the DALI operating devices with a DALI bus. One 
e-touchPANEL can access a maximum of 2 x 60 operating devices.

Hint

Please observe the information on the Ethernet interface and address allocation in the user manual 
›e-touchBOX/PANEL‹.
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3 Installation

3.1 System requirements
In order for the ›em-LINK‹ program to operate at its optimum the following requirements must be 
met:

3.2 Installing the program
You can download the program ›em-LINK‹ free of cost from the Tridonic.Atco GmbH & Co KG 
homepage (www.tridonicatco.com -> Services -> Download -> ›em-LINK‹).

Apart from ›em-LINK‹ the following programs are required:

›MS Access JET Engine‹ (MDAC), version 2.8 or higher
›.NET Framework‹, version 2.0 or higher
›Java Platform Standard Edition‹, version 6 or higher
›MS Internet Explorer‹, version 7 or higher
›Adobe Reader‹, version 7

1. Double-click on the setup.exe symbol.
The installation assistant is displayed.

2. Follow the instructions of the installation assistant ›em-LINK‹ Setup Wizard.

PC/laptop Standard

Operating system ›MS Windows 2000‹ / ›XP‹ / ›Vista‹

Screen resolution minimum XGA (1024x768 pixels)

Communication Ethernet connection
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4 Starting and exiting the program

4.1 Starting the program
Double-click on the ›em-LINK‹ symbol to start the program.

4.2 Exiting the program
To exit the program, click on Quit em-Link in the Data menu.
The program is closed.

5 User interface

The user interface is divided into an information area and a main area.

1 Title bar
2 Menu bar
3 Tool bar
4 Information area
5 Main area

Hint

In order to keep the performance of the PC and the free storage area at a constant level, 
TridonicAtco recommends switching off the PC for a short time once a week.

Hint

The data you have downloaded from the e-touchPANEL are stored in the program and are 
available again when the program is restarted.
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5.1 Overview window
The Overview window displays those e-touchPANEL in the main area that were entered in the 
Panel List Editor in the ›em-LINK‹. The status, name and annotation are displayed for each 
e-touchPANEL. 

The information area displays a summary of the status of all edited e-touchPANEL. An error is 
indicated if one or several e-touchPANEL are not connected or if an ›Error‹ is present.

Area Display Meaning

1 Information area Status of emergency lighting 
system: ›OK‹

All e-touchPANEL connected
All e-touchPANEL in status: ›OK‹

Status of emergency lighting 
system: ›Error‹

One or several e-touchPANEL 
not connected
For one or several 
e-touchPANEL the status is: 
›Error‹ (e. g. lamp defective, 
battery fault)

2 Main area Status e-touchPANEL: ›OK‹

Status e-touchPANEL: ›Establishing 
Connection‹

Status e-touchPANEL: ›No 
connection‹

Status e-touchPANEL: ›Error‹

0 panel(s) with error
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5.2 Remoteview window
In the Remoteview window, the e-touchPANEL is operated using the keyboard and the mouse 
pointer. 

1 List of e-touchPANEL
2 Annotation for the selected e-touchPANEL
3 Date and time when test protocols were downloaded last
4 User interface of the selected e-touchPANEL
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5.3 Menus

5.4 Symbols

Menu Command Meaning

Data Download from Panel Downloads the data of the most recently generated test 
protocols to the database of the program.

Show Data Opens the dialog box to select the e-touchPANEL. The 
corresponding test protocols are displayed.

Report Wizard Opens the dialog box for generating a report (a report 
contains filtered data of the test protocols in txt format).

Export to Excel Exports the displayed data in csv format (e. g. for further 
processing in ›MS Excel‹).

Quit em-Link Closes the program.

View Overview Opens the Overview window. 

Remoteview Opens the Remoteview window.

Options Languages Sets the program language.

Properties/Edit Panel 
List

Opens the dialog box for the connection with 
e-touchPANEL. 

Properties/Edit 
Customer Info

Opens the dialog box for customer information.

Update Panel Firmware Opens the browser for downloading.

Help em-Link User Manual Opens the ›em-LINK‹ user manual. 

About ›em-LINK‹ Provides information about the program ›em-LINK‹.

Symbol Command Meaning

Change to Overview Opens the Overview window.

Change to Remoteview Opens the Remoteview window.

Download Results from 
Panel

Downloads the data of the most recently generated test 
protocols to the database of the program.

Displaying the data in 
the database

Opens the dialog box to select the e-touchPANEL. The 
corresponding test protocols are displayed.

Generate Report Opens the dialog box for generating a report (filtered 
data of the test protocols in txt format).

Export to Excel Exports the displayed data in csv format, e. g. for further 
processing in ›MS Excel‹).
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6 Configuration

6.1 Selecting the language
The language of the user interface can be selected in the Options menu.

1. Click on the desired language in the Options/Languages menu.

You are prompted to restart the program.
2. Exit and restart the program.

The selected language is now used.

6.2 Entering customer information
Customer information appears at the beginning of a report and facilitates allocating the reports. 
Customer information can be freely entered. A maximum of 360 characters may be used. 

1. Click on Edit Customer Info in the Options/Properties menu.
The dialog box Customer Info Editor is displayed.

2. Enter the customer information and confirm with OK.
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7 Establishing the connection to e-touchPanel

In order to establish the connection between ›em-LINK‹ and e-touchPANEL, you have to edit the 
addresses of the e-touchPANEL in the dialog box Panel List Editor.

The Panel List Editor contains the following input fields. An input field may contain no more than 
80 characters. 

– e-touchPANEL are installed and addressed.

– Addresses of the e-touchPANEL are available.

1. Click on Edit Panel List in the Options/Properties menu.

The dialog box Panel List Editor is displayed.

2. Enter the Panel Name, IP Address, MAC Address and Annotation (optional) for the 

e-touchPANEL.
3. Repeat step 2 if you want to connect additional e-touchPANEL.
4. Click on the OK button.

Addresses and annotations are stored in the program. ›em-LINK‹ and e-touchPANEL are now 
connected.

Input field Meaning

Panel Name You can transfer the Panel Name from the e-touchPANEL or you can assign a 
name of your choice. The panel name is used to differentiate between several 
e-touchPANEL. In the e-touchPANEL, the Panel Name is displayed in the 
System tab of the Configuration menu  (see user manual ›e-touchBOX/
PANEL‹).

IP Address The IP Address(protocol address) is required to establish the connection. The 
IP address is displayed in the e-touchPANEL in the TCP tab of the 
Configuration menu (see user manual ›e-touchBOX/PANEL‹). 

MAC Address The MAC Address (specific device address) is required to establish the 
connection. The IP address is displayed in the e-touchPANEL in the TCP tab of 
the Configuration menu (see user manual ›e-touchBOX/PANEL‹). 

Annotation Annotations on the e-touchPANEL can be entered in the input field Annotation. 
The annotation appears in the information area of the Overview window and is 
output in the report.

Hint

A list that contains the addresses facilitates entries in the Panel List Editor. In the Remoteview 
window you can open the TCP window for each e-touchPANEL and transfer the addresses to a list 
(see user manual ›e-touchBOX/PANEL‹, chapter ›Schedule for Ethernet connections‹).
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8 Monitoring

Error message With ›em-LINK‹, all e-touchPANEL of an emergency lighting system can be monitored centrally. In 
the Overview window, the status of every edited e-touchPANEL is displayed (see "Overview 
window", page 5).

If an error is indicated you can, e.g., use the remote control to start a test protocol for the 
corresponding e-touchPANEL in order to analyse the error (see user manual for ›e-touchBOX/
PANEL‹, chapter ›Manually testing emergency units‹). 

9 Managing test protocols/reports

The test protocols of the e-touchPANEL are stored in a database in ›em-LINK‹. This makes it 
possible to filter the test protocols and to generate different reports (see "Generating a report", 
page 12). The data display can be stored in txt format (report) or exported in csv format (e.g. for 
›MS Excel‹).

Standard report The following figure shows an example of a Standard report. The report starts with the customer 
information. In the Report Comment section, the annotations from the Report Wizard are 
displayed. Below the report comment, the data for the individual e-touchPANEL are displayed 
depending on your selection. 
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Extended report The following figure shows an example of an Extended report. In addition to the entries in the 
standard report, the extended report contains information on the DALI operating devices 
connected with the e-touchPANEL.

9.1 Downloading test protocols from e-touchPANEL
The test protocols of the e-touchPANEL are stored in the ›em-LINK‹ database.

1. Click on the Download Results from Panel symbol.
The Download from panel window is displayed.

Hint

In the case of more than one e-touchPANEL, downloading can take up to several minutes.
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2. Select one or several e-touchPANEL and click on the Finish button.
An information window indicates that downloading is completed.

3. Click on the OK button.
The test protocols of the e-touchPANEL are now stored in the ›em-LINK‹ database.

9.2 Generating a report
Depending on your requirements, you can generate reports from the test protocols that are stored 
in the database. You can supplement the data with comments and filter, store or print them. In this 
way you can generate customer or system-specific reports.

The following filtering criteria are available:

Selecting the e-touchPANEL
Only data of the e-touchPANEL where an error message has occurred or data of all 
e-touchPANEL
Selecting the time interval
- Protocols of the last test run
- All test protocols
- Test protocols of a specified time interval

The following paragraph describes how to generate different types of reports.

Show Data Select the e-touchPANEL for which you want to generate a report in the dialog box Show Data. 
The currently connected e-touchPANEL are marked with an *. The e-touchPANEL that were 
replaced are not marked.

1. Click on the Show Data from Database symbol.
The dialog box Show Data appears where list of the edited e-touchPANEL is displayed.

2. Select one or several e-touchPANEL.
3. Click on the Next button.

The dialog box with the Last Results list and the Show only Errors check box is displayed.
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The following options are possible:

Last Results: The data downloaded last are displayed. 
Show only Errors: Only data that contain error messages are displayed.
Several Results: Either all data or the data of a specific time interval are displayed.

Displaying the data of
the test protocols
downloaded last

1. In the dialog box, select Last Results from the list.

2. Activate or deactivate the Show only Errors check box.
3. Click on the Finish button.

The data downloaded last are displayed in a table. The dialog box Generate Report? is 
displayed.

Hint

Use Drag&Drop to change the sequence of the columns of a report. If you double-click on the 
entry in a column header, the table after this column is sorted upward or downward.
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 Displaying data of
several test protocols

1. In the dialog box, select Several Results from the list.

2. Click on the Next button.
The dialog box is displayed where you can filter the data further.

3. In order to generate a report from all displayed data, select All Dates from the list and click on 
the Finish button.

- or -
In order to generate a report from the data of a specific time interval, select Specific Dates from 
the list, specify the date, and click on the Finish button.

The selected data are displayed in a table. The dialog box Generate Report? is displayed.
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Generating a report A comment can be entered for each report. 

1. In order to generate a report from the data displayed, click on the Yes button.
- or -
Click on Report Wizard in the Data menu.

The dialog box Report Wizard is displayed.

2. You can enter a comment in the input field.

3. Activate the Show extended Report check box in order to generate an extended report.
4. Click on the Finish button.

The dialog box Report Preview is displayed.
5. To save the report, click on Save as in the File menu.

The report is stored in txt format.
6. To print the report, click on Print in the File menu.

9.3 Exporting data to Excel
You can store the displayed data in csv format and, e. g., further process them in ›MS Excel‹.

– Show Data is open.

1. Click on Export to Excel in the Data menu.

The dialog box Export to csv File is displayed.
2. Select the folder and change the file name if required.
3. Click on the Save button.

The data are stored in csv format.
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10 Remote control

›em-LINK‹ enables the configuration and operation of every connected e-touchPANEL. With the 
remote control, all functions can be accessed using the keyboard and the mouse. The 
touchscreen of the e-touchPANEL and the user interface of the ›em-LINK‹ are synchronized in real 
time. 

10.1 Remote control of e-touchPANEL with ›em-LINK‹
– ›em-LINK‹ and e-touchPANEL are connected.

Click on the e-touchPANEL symbol in the Overview window.

- or -

Select the name of the e-touchPANEL in the Panel list of the Remoteview window.

The active window of the selected e-touchPANEL is displayed in the main area of the 
Remoteview window. 

In the Remoteview window, entries can be made directly via the keyboard. Click on a letter/
number in the displayed keyboard to activate the keyboard input.

Hint

The notes and information in the user manual ›e-touchBOX/PANEL‹ must always be observed!
This user manual describes how to configure and operate a e-touchPANEL and how to set time-
controlled function and duration tests.

Hint

Click on the screensaver of the e-touchPANEL if the screensaver is displayed. The window that 
was open last appears.
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11 Updating the firmware of the e-touchPANEL

With ›em-LINK‹ you can update the firmware of the e-touchPANEL. The currently valid firmware is 
available on the TridonicAtco homepage (www.tridonicatco.com). 

– The current firmware is stored locally.

– The e-touchPANEL whose firmware you wish to update is marked in the Overview window.

1. Click on the e-touchPANEL symbol in the Overview window.

- or -
Select the name of the e-touchPANEL in the Panel list of the Remoteview window.

2. Click on Update Panel Firmware in the Options menu.
A browser window is displayed. The name of the e-touchPANEL is displayed (e. g. 
›e-touch alpha‹).

3. Click on the Durchsuchen (Browse) button and select the firmware file. 
The firmware file path is displayed in the input field.

4. Click on the upload button.
5. Confirm the security enquiry with OK.

The firmware of the selected e-touchPANEL is updated.
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12 Help in the case of problems

12.1 e-touchPANEL not responding

Reason:

e-touchPANEL is not switched on.
Connect e-touchPANEL to the power supply. 

Reason:

Cable connected incorrectly.
Refer to the ›e-touchBOX/PANEL‹ user manual and contact an IT specialist if necessary.

Reason:

No Ethernet connection
Refer to the ›e-touchBOX/PANEL‹ user manual and contact an IT specialist if necessary.
Ensure that the MAC Address, IP Address and Subnet Mask in the Panel List Editor match the 
address of the e-touchPANEL (see "Establishing the connection to e-touchPanel", page 9).
Ensure that the addressing process for the e-touchPANEL is finished.
Ensure that no Internet security systems are connected that could inhibit communication (e. g. 
Firewall).

Reason:

›em-LINK‹ is started while the e-touchPANEL are put into operation.

1. Close ›em-LINK‹. 
2. Switch off e-touchPANEL briefly. 

3. Restart ›em-LINK‹.

12.2 Keyboard entries via remote control not possible
In the Remoteview window no entries can be made via the keyboard (see "Remote control", 
page 16). 

Reason:

Keyboard interface has not been activated.
Click on the panel keyboard using the mouse in order to activate the keyboard interface. 

Reason:

›Java Runtime Environment‹ version is out of date.
Update ›Java Runtime Environment‹ version. 
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13 Replacing an e-touchPANEL

If you want to replace an e-touchPANEL you can assign the same IP address and the same name 
for the new e-touchPANEL. The MAC address is device-specific and must be adapted. 
Replacements are documented and can be retraced since the MAC addresses are given in the 
test protocols and in the reports. 

1. Replace e-touchPANEL and connect it to the power supply.

2. Connect ›em-LINK‹ and e-touchPANEL (see "Establishing the connection to e-touchPanel", 
page 9).

Hint

Within an emergency lighting system the e-touchPANEL must not be interchanged since it is not 
possible to include this in the test protocols.
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